Pikdev para KDE4

    Pensaba instalar Pikdev para programar PICs con mi nuevo PICkit2, para ello he utilizado este tutorial http://pic-linux.foroactivo.net/otros-f19/pickit-2-trabajando-pikdev-v-110-t86.htm porcierto el foro tiene muy buena pinta, me ha gustado. Pero cual es el problema que el paquete de Pikdev está un poco anticuado y tiene una dependencia de kdelibs4-dev que no me gusta nada sobretodo porque vamos por la kdelibs5-dev que es la que utiliza KDE4 y como también estoy empezando programar para KDE4 tenia problemas de dependencias. La solucion es simple, se cambian la dependencia del archivo kdelibs4-dev por kdelibs5-dev. ¿Que como se hace esto? Pues antes que nada con el archivo descargado en home por ejemplo, creamos una carpeta temporal:

    mkdir temporal

    En esta carpeta temporal desempaquetamos el deb:

    dpkg-deb --extract paquete.deb temporal

    En nuestro caso donde pone paquete.deb sera el nombre del paquete pikdev_1.1.0-1_i386.deb.

    Luego extraemos la parte de control.

    dpkg-deb --control paquete.deb temporal/DEBIAN

    Luego abrimos el archivo de texto temporal/DEBIAN/control y modificamos las dependencias, donde pone kdelibs4-dev ponemos kdelibs5-dev.

    Después de esto solo queda reempaquetar la carpeta temporal.

    dpkg --build temporal

    He renombrado el paquete con el nombre pikdev_1.1.0-2_i386.deb, y está colgado en megaupload para quien lo quiera todo mascadito.


    Profile picture

    Carlos Sanmartín Bustos

    Desarrollador de software embebido comprometido con el software libre. Progresista y antiautoritario.